aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-04-04 21:32:31 -0400
committerDrew DeVault <sir@cmpwn.com>2018-04-05 00:03:20 -0400
commitf77986338fc4186d003908012685c12d718ed647 (patch)
treef8b1ec4af069ab2123453d713251dcd7c51767d1 /sway/meson.build
parent21aedf15052df4e7f8ee72922fa0e214d690facc (diff)
Implement resize command
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build46
1 files changed, 27 insertions, 19 deletions
diff --git a/sway/meson.build b/sway/meson.build
index f210c195..ec7b4c42 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -2,10 +2,28 @@ sway_sources = files(
'main.c',
'server.c',
'commands.c',
+ 'config.c',
+ 'criteria.c',
+ 'ipc-json.c',
+ 'ipc-server.c',
+ 'security.c',
+
+ 'desktop/output.c',
+ 'desktop/layer_shell.c',
+ 'desktop/wl_shell.c',
+ 'desktop/xdg_shell_v6.c',
+ 'desktop/xwayland.c',
+
'input/input-manager.c',
'input/seat.c',
'input/cursor.c',
'input/keyboard.c',
+
+ 'config/bar.c',
+ 'config/output.c',
+ 'config/seat.c',
+ 'config/input.c',
+
'commands/bar.c',
'commands/bind.c',
'commands/default_orientation.c',
@@ -20,13 +38,19 @@ sway_sources = files(
'commands/input.c',
'commands/layout.c',
'commands/mode.c',
- 'commands/split.c',
+ 'commands/mouse_warping.c',
'commands/move.c',
+ 'commands/output.c',
+ 'commands/reload.c',
+ 'commands/resize.c',
'commands/seat.c',
'commands/seat/attach.c',
'commands/seat/fallback.c',
'commands/set.c',
+ 'commands/split.c',
'commands/swaybg_command.c',
+ 'commands/workspace.c',
+
'commands/bar/activate_button.c',
'commands/bar/binding_mode_indicator.c',
'commands/bar/bindsym.c',
@@ -51,6 +75,7 @@ sway_sources = files(
'commands/bar/tray_padding.c',
'commands/bar/workspace_buttons.c',
'commands/bar/wrap_scroll.c',
+
'commands/input/accel_profile.c',
'commands/input/click_method.c',
'commands/input/drag_lock.c',
@@ -67,24 +92,7 @@ sway_sources = files(
'commands/input/xkb_options.c',
'commands/input/xkb_rules.c',
'commands/input/xkb_variant.c',
- 'commands/mouse_warping.c',
- 'commands/output.c',
- 'commands/reload.c',
- 'commands/workspace.c',
- 'config.c',
- 'config/bar.c',
- 'config/output.c',
- 'config/seat.c',
- 'config/input.c',
- 'criteria.c',
- 'ipc-json.c',
- 'ipc-server.c',
- 'desktop/output.c',
- 'desktop/layer_shell.c',
- 'desktop/wl_shell.c',
- 'desktop/xdg_shell_v6.c',
- 'desktop/xwayland.c',
- 'security.c',
+
'tree/container.c',
'tree/layout.c',
'tree/view.c',