aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorTony Crisci <tony@dubstepdish.com>2017-11-30 06:25:13 -0500
committerTony Crisci <tony@dubstepdish.com>2017-11-30 06:25:13 -0500
commitcc310cffb0bf4cd2333be26a2ae16848655a306b (patch)
tree83fe5f45fbcb7866a32ce7a9c9f132acb2860f6c /sway/meson.build
parent739bafbd8ecdbbf2eb3fd42e1b3d9249236a3fcf (diff)
meson: common static library
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 1f17ed31..b02506c8 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -1,4 +1,4 @@
-sway_sources = sway_common + files(
+sway_sources = files(
'main.c',
'server.c',
'commands.c',
@@ -25,5 +25,6 @@ executable(
'sway',
sway_sources,
include_directories: [sway_inc],
- dependencies: sway_deps
+ dependencies: sway_deps,
+ link_with: [lib_sway_common]
)