aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorRyan Dwyer <RyanDwyer@users.noreply.github.com>2018-08-02 23:05:49 +1000
committerGitHub <noreply@github.com>2018-08-02 23:05:49 +1000
commit706c0fbe2376e15f8140be60f3c8b0713128ebba (patch)
treeffefcdd261970549f8b83adae8d93b6c3b9ebbbb /sway/meson.build
parent26c5ef18ba295e016074c9d87affe5da44e71cb1 (diff)
parent8e60f6a73263c444ab5fecdeacdaf7883a9b1505 (diff)
downloadsway-706c0fbe2376e15f8140be60f3c8b0713128ebba.tar.xz
Merge branch 'master' into nagbar
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/sway/meson.build b/sway/meson.build
index d92bb905..a9503c3b 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -153,10 +153,6 @@ sway_sources = files(
'tree/output.c',
)
-if get_option('enable-xwayland')
- sway_sources += 'desktop/xwayland.c'
-endif
-
sway_deps = [
cairo,
gdk_pixbuf,
@@ -170,10 +166,14 @@ sway_deps = [
server_protos,
wayland_server,
wlroots,
- xcb,
xkbcommon,
]
+if get_option('enable-xwayland')
+ sway_sources += 'desktop/xwayland.c'
+ sway_deps += xcb
+endif
+
executable(
'sway',
sway_sources,