aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-01-18 15:39:07 -0500
committerGitHub <noreply@github.com>2019-01-18 15:39:07 -0500
commit639b66b6769722b5decc8f7a21dd7c5037f3c65c (patch)
treecd93e26b01fe51b76b124b334057011c81974859 /sway/meson.build
parent60220fcecd1d30c022b3137372d339204e8238c6 (diff)
parent765d7bc94f1b02f0b1135b6412dab8654ec2ac31 (diff)
Merge pull request #3452 from emersion/meson-features
Use Meson feature options
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 0a08ee74..94d5abdb 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -194,7 +194,7 @@ sway_deps = [
xkbcommon,
]
-if get_option('enable-xwayland')
+if have_xwayland
sway_sources += 'desktop/xwayland.c'
sway_deps += xcb
endif
@@ -205,6 +205,5 @@ executable(
include_directories: [sway_inc],
dependencies: sway_deps,
link_with: [lib_sway_common],
- install_rpath : rpathdir,
install: true
)