aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-12-20 11:56:39 -0500
committerGitHub <noreply@github.com>2017-12-20 11:56:39 -0500
commit373def44468e0c919031a6ffe3049f91680e05ca (patch)
treee40dfdcc9292a71fcc2160bc5d643a66996664dc /sway/meson.build
parenta51e74beb91a98181d6bc69137d377cd49e72d1f (diff)
parent63f7fb95172a72436698a1562b4f7ea1e9100a7e (diff)
Merge pull request #1505 from acrisci/feature/input
input management and seat
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index e16691a8..fee2ddd2 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -2,13 +2,39 @@ sway_sources = files(
'main.c',
'server.c',
'commands.c',
+ 'input/input-manager.c',
+ 'input/seat.c',
+ 'input/cursor.c',
+ 'input/keyboard.c',
'commands/exit.c',
'commands/exec.c',
'commands/exec_always.c',
'commands/include.c',
+ 'commands/input.c',
+ 'commands/seat.c',
+ 'commands/seat/attach.c',
+ 'commands/seat/fallback.c',
+ 'commands/input/accel_profile.c',
+ 'commands/input/click_method.c',
+ 'commands/input/drag_lock.c',
+ 'commands/input/dwt.c',
+ 'commands/input/events.c',
+ 'commands/input/left_handed.c',
+ 'commands/input/middle_emulation.c',
+ 'commands/input/natural_scroll.c',
+ 'commands/input/pointer_accel.c',
+ 'commands/input/scroll_method.c',
+ 'commands/input/tap.c',
+ 'commands/input/xkb_layout.c',
+ 'commands/input/xkb_model.c',
+ 'commands/input/xkb_options.c',
+ 'commands/input/xkb_rules.c',
+ 'commands/input/xkb_variant.c',
'commands/output.c',
'config.c',
'config/output.c',
+ 'config/seat.c',
+ 'config/input.c',
'ipc-json.c',
'ipc-server.c',
'desktop/output.c',
@@ -28,6 +54,8 @@ sway_deps = [
wlroots,
libcap,
math,
+ libinput,
+ xkbcommon,
]
executable(