aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-12-11 11:00:39 -0500
committerDrew DeVault <sir@cmpwn.com>2019-12-12 10:37:30 -0500
commit2f3c6cccf5d6b2d6ffd3cee62e7b624dc80dc6e6 (patch)
tree69d3367cf7dbd7f756d45d89cd37e6016503a88d /sway/meson.build
parentf645f8efd688104cdeac01cd940b32a8ff978571 (diff)
Add seat <seat> idle_{inhibit,wake} <sources...>
This adds seat configuration options which can be used to configure what events affect the idle behavior of sway. An example use-case is mobile devices: you would remove touch from the list of idle_wake events. This allows the phone to stay on while you're actively using it, but doesn't wake from idle on touch events while it's sleeping in your pocket.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 3e6e4da6..20fe02fb 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -91,6 +91,7 @@ sway_sources = files(
'commands/seat/cursor.c',
'commands/seat/fallback.c',
'commands/seat/hide_cursor.c',
+ 'commands/seat/idle.c',
'commands/seat/keyboard_grouping.c',
'commands/seat/pointer_constraint.c',
'commands/seat/xcursor_theme.c',