aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-12-01 08:21:01 -0500
committerGitHub <noreply@github.com>2017-12-01 08:21:01 -0500
commit1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254 (patch)
treeb74002984ff80201c02ed9c22ca2fe1cdae98e23 /sway/meson.build
parent1fbcd097ae2841b5f8f56cf67c1e94605deb0d25 (diff)
parent3546412fc9fb9a51b4316070eff4991c14594127 (diff)
downloadsway-1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254.tar.xz
Merge pull request #1479 from acrisci/feature/meson-build
meson build
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
new file mode 100644
index 00000000..cf2aa913
--- /dev/null
+++ b/sway/meson.build
@@ -0,0 +1,31 @@
+sway_sources = files(
+ 'main.c',
+ 'server.c',
+ 'commands.c',
+ 'commands/exit.c',
+ 'ipc-json.c',
+ 'ipc-server.c',
+ 'desktop/output.c',
+ 'desktop/xdg_shell_v6.c',
+ 'tree/container.c',
+ 'tree/layout.c',
+ 'tree/workspace.c',
+)
+
+sway_deps = [
+ pixman,
+ wayland_server,
+ jsonc,
+ wlroots,
+ libcap,
+ math,
+]
+
+executable(
+ 'sway',
+ sway_sources,
+ include_directories: [sway_inc],
+ dependencies: sway_deps,
+ link_with: [lib_sway_common],
+ install: true
+)