aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorBrian Ashworth <bosrsf04@gmail.com>2019-07-18 01:06:25 -0400
committerSimon Ser <contact@emersion.fr>2019-07-23 20:45:46 +0300
commit1a16262903dce09a60f94698afa96c1b2c91c264 (patch)
tree5232ce26dccf8008bcc2cb0cda95dcde382e1c39 /sway/meson.build
parent6effca7b61e87c7d17885d007d94e556a0137651 (diff)
ipc: add input::libinput_config event
This adds a libinput_config change type to the input event for when the libinput config for a device changes In order for this to be possible to track, the libinput config code had to be refactored. It is now extracted into a separate file to isolate it from the rest of the input management code.
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 934dbe68..157e3996 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -21,6 +21,9 @@ sway_sources = files(
'desktop/xdg_shell.c',
'input/input-manager.c',
+ 'input/cursor.c',
+ 'input/keyboard.c',
+ 'input/libinput.c',
'input/seat.c',
'input/seatop_default.c',
'input/seatop_down.c',
@@ -28,8 +31,6 @@ sway_sources = files(
'input/seatop_move_tiling.c',
'input/seatop_resize_floating.c',
'input/seatop_resize_tiling.c',
- 'input/cursor.c',
- 'input/keyboard.c',
'input/switch.c',
'config/bar.c',