aboutsummaryrefslogtreecommitdiff
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2016-12-11 14:07:08 -0500
committerGitHub <noreply@github.com>2016-12-11 14:07:08 -0500
commit6350752d6be2abfac68aa16e891dd859aa5cdafa (patch)
tree18c24336e664111ba9c3a5bfedec5c340ec0a19d /sway/CMakeLists.txt
parentd93e53fd4b57c478097aee899da8226acfe3d318 (diff)
parentda26d69cb1b21d582a81af0cad7342fab6596eed (diff)
Merge pull request #985 from myfreeweb/master
Fix build on FreeBSD
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index d1afadb6..4532a6c3 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -55,9 +55,12 @@ target_link_libraries(sway
${PANGO_LIBRARIES}
${JSONC_LIBRARIES}
m
- cap
)
+if (CMAKE_SYSTEM_NAME STREQUAL Linux)
+ target_link_libraries(sway cap)
+endif (CMAKE_SYSTEM_NAME STREQUAL Linux)
+
install(
TARGETS sway
RUNTIME