aboutsummaryrefslogtreecommitdiff
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2016-12-04 08:30:40 -0500
committerGitHub <noreply@github.com>2016-12-04 08:30:40 -0500
commit5778c59a2f302071fd781683db57a97b51396c87 (patch)
treee0ec272832e88e6c8d92719efa70c6749452daff /sway/CMakeLists.txt
parentcd5694fdb5bc9beb575902ea57d037833ad8e85c (diff)
parente7a764fdf450a8259ddbc17446dd720fa1157b44 (diff)
downloadsway-5778c59a2f302071fd781683db57a97b51396c87.tar.xz
Merge pull request #981 from SirCmpwn/security
Security features
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt33
1 files changed, 28 insertions, 5 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index bb9ea81f..d1afadb6 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -35,6 +35,7 @@ add_executable(sway
output.c
workspace.c
border.c
+ security.c
)
add_definitions(
@@ -54,6 +55,7 @@ target_link_libraries(sway
${PANGO_LIBRARIES}
${JSONC_LIBRARIES}
m
+ cap
)
install(
@@ -62,13 +64,34 @@ install(
DESTINATION bin
COMPONENT runtime
)
-install(
- FILES ${PROJECT_SOURCE_DIR}/config
- DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/sway/
- COMPONENT configuration
-)
+
+add_custom_target(configs ALL)
+
+function(add_config name source destination)
+ add_custom_command(
+ OUTPUT ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
+ COMMAND sed -r
+ 's?__PREFIX__?${CMAKE_INSTALL_PREFIX}?g\; s?__SYSCONFDIR__?${CMAKE_INSTALL_FULL_SYSCONFDIR}?g'
+ ${PROJECT_SOURCE_DIR}/${source}.in > ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
+ DEPENDS ${PROJECT_SOURCE_DIR}/${source}.in
+ COMMENT "Generating config file ${source}"
+ )
+
+ install(
+ FILES ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
+ DESTINATION ${CMAKE_INSTALL_FULL_SYSCONFDIR}/${destination}
+ COMPONENT configuration
+ )
+
+ add_custom_target(config-${name} DEPENDS ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name})
+ add_dependencies(configs config-${name})
+endfunction()
+
+add_config(config config sway)
+add_config(security config.d/security sway/config.d)
add_manpage(sway 1)
add_manpage(sway 5)
add_manpage(sway-input 5)
add_manpage(sway-bar 5)
+add_manpage(sway-security 7)