aboutsummaryrefslogtreecommitdiff
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-12-01 08:21:01 -0500
committerGitHub <noreply@github.com>2017-12-01 08:21:01 -0500
commit1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254 (patch)
treeb74002984ff80201c02ed9c22ca2fe1cdae98e23 /sway/CMakeLists.txt
parent1fbcd097ae2841b5f8f56cf67c1e94605deb0d25 (diff)
parent3546412fc9fb9a51b4316070eff4991c14594127 (diff)
Merge pull request #1479 from acrisci/feature/meson-build
meson build
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt96
1 files changed, 0 insertions, 96 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
deleted file mode 100644
index 274fcc4a..00000000
--- a/sway/CMakeLists.txt
+++ /dev/null
@@ -1,96 +0,0 @@
-include_directories(
- ${PROTOCOLS_INCLUDE_DIRS}
- ${WLR_INCLUDE_DIRS}
- ${PCRE_INCLUDE_DIRS}
- ${JSONC_INCLUDE_DIRS}
- ${XKBCOMMON_INCLUDE_DIRS}
- ${LIBINPUT_INCLUDE_DIRS}
- ${CAIRO_INCLUDE_DIRS}
- ${PANGO_INCLUDE_DIRS}
- ${WAYLAND_INCLUDE_DIR}
-)
-
-add_executable(sway
- desktop/output.c
- desktop/xdg_shell_v6.c
-
- commands.c
- commands/exit.c
-
- tree/container.c
- tree/layout.c
- tree/workspace.c
-
- base64.c
- main.c
- server.c
- ipc-json.c
- ipc-server.c
-)
-
-add_definitions(
- -DSYSCONFDIR="${CMAKE_INSTALL_FULL_SYSCONFDIR}"
-)
-
-target_link_libraries(sway
- sway-common
- sway-protocols
- sway-wayland
- ${WLR_LIBRARIES}
- ${XKBCOMMON_LIBRARIES}
- ${PCRE_LIBRARIES}
- ${JSONC_LIBRARIES}
- ${WAYLAND_SERVER_LIBRARIES}
- ${LIBINPUT_LIBRARIES}
- ${PANGO_LIBRARIES}
- ${JSONC_LIBRARIES}
- m
-)
-
-if (CMAKE_SYSTEM_NAME STREQUAL Linux)
- target_link_libraries(sway cap)
-endif (CMAKE_SYSTEM_NAME STREQUAL Linux)
-
-install(
- TARGETS sway
- RUNTIME
- DESTINATION bin
- COMPONENT runtime
-)
-
-add_custom_target(configs ALL)
-
-function(add_config name source destination)
- add_custom_command(
- OUTPUT ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
- COMMAND sed -r
- 's?__PREFIX__?${CMAKE_INSTALL_PREFIX}?g\; s?__SYSCONFDIR__?${CMAKE_INSTALL_FULL_SYSCONFDIR}?g\; s?__DATADIR__?${CMAKE_INSTALL_FULL_DATADIR}?g'
- ${PROJECT_SOURCE_DIR}/${source}.in > ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
- DEPENDS ${PROJECT_SOURCE_DIR}/${source}.in
- COMMENT "Generating config file ${source}"
- )
-
- install(
- FILES ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}
- DESTINATION ${CMAKE_INSTALL_FULL_SYSCONFDIR}/${destination}
- COMPONENT configuration
- )
-
- add_custom_target(config-${name} DEPENDS ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name})
- add_dependencies(configs config-${name})
-endfunction()
-
-add_config(config config sway)
-add_config(00-defaults security.d/00-defaults sway/security.d)
-
-if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
- add_config(10-freebsd security.d/10-freebsd sway/security.d)
-endif (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
-
-if (A2X_FOUND)
- add_manpage(sway 1)
- add_manpage(sway 5)
- add_manpage(sway-input 5)
- add_manpage(sway-bar 5)
- add_manpage(sway-security 7)
-endif()