aboutsummaryrefslogtreecommitdiff
path: root/protocols/meson.build
diff options
context:
space:
mode:
authorDominique Martinet <asmadeus@codewreck.org>2018-04-13 14:54:08 +0900
committerDominique Martinet <asmadeus@codewreck.org>2018-04-13 22:37:37 +0900
commit9073c9a6c73f3f2f48341367e255f7e4a0a644a9 (patch)
treed12f1a951037d37d17031249ae80ee52bf684ba9 /protocols/meson.build
parent3dd185ec04bd3e4e1e34799adc4d7c28e4ab880c (diff)
Use 'private-code' for wayland-scanner code generation
Same as for wlroots - autodetect version and use either 'code' or the new one
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
index 7f83b16b..9d213f81 100644
--- a/protocols/meson.build
+++ b/protocols/meson.build
@@ -2,10 +2,17 @@ wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
wayland_scanner = find_program('wayland-scanner')
+# should check wayland_scanner's version, but it is hard to get
+if wayland_server.version().version_compare('>=1.14.91')
+ code_type = 'private-code'
+else
+ code_type = 'code'
+endif
+
wayland_scanner_code = generator(
wayland_scanner,
output: '@BASENAME@-protocol.c',
- arguments: ['code', '@INPUT@', '@OUTPUT@'],
+ arguments: [code_type, '@INPUT@', '@OUTPUT@'],
)
wayland_scanner_client = generator(