aboutsummaryrefslogtreecommitdiff
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
committerDrew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
commitcd1b32453a9296c18b28bff71607aeb22987b5cd (patch)
treec653c6d525b471914c01a9d7ae543f521b6138ed /protocols/CMakeLists.txt
parent8e06985cc1b479724446fba752e0fecfb998e87b (diff)
parent5785170421dc38437acde8bb61068cd16fda716c (diff)
Merge branch 'wlroots'
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt46
1 files changed, 0 insertions, 46 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
deleted file mode 100644
index 8d8e58ad..00000000
--- a/protocols/CMakeLists.txt
+++ /dev/null
@@ -1,46 +0,0 @@
-include(Wayland)
-
-WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-xdg-shell
- xdg-shell.xml
- xdg-shell
-)
-WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-desktop-shell
- desktop-shell.xml
- desktop-shell
-)
-WAYLAND_ADD_PROTOCOL_SERVER(proto-server-desktop-shell
- desktop-shell.xml
- desktop-shell
-)
-
-WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-swaylock
- swaylock.xml
- swaylock
-)
-WAYLAND_ADD_PROTOCOL_SERVER(proto-server-swaylock
- swaylock.xml
- swaylock
-)
-
-WAYLAND_ADD_PROTOCOL_SERVER(proto-server-gamma-control
- gamma-control.xml
- gamma-control
-)
-
-WAYLAND_ADD_PROTOCOL_SERVER(proto-server-server-decoration
- server-decoration.xml
- server-decoration
-)
-
-add_library(sway-protocols STATIC
- ${proto-client-xdg-shell}
- ${proto-client-desktop-shell}
- ${proto-server-desktop-shell}
- ${proto-client-swaylock}
- ${proto-server-swaylock}
- ${proto-server-gamma-control}
- ${proto-server-server-decoration}
- )
-
-set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)
-INCLUDE_DIRECTORIES(${WAYLAND_INCLUDE_DIR} ${XKBCOMMON_INCLUDE_DIRS})