aboutsummaryrefslogtreecommitdiff
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2015-12-03 08:35:22 -0500
committerDrew DeVault <sir@cmpwn.com>2015-12-03 08:35:22 -0500
commit71afa388906bf29dcd937aa92b65a97c8b320f60 (patch)
tree7e7efa0fccde6eb99b1b1bd9d20b1d0f1b2b5f3b /protocols/CMakeLists.txt
parent2b38f298ff23b73ea26fc900c4422c2c4dd85bba (diff)
Add swaylock protocol, add resource destructors
This prevents sway crashing if swaybg or swaybar dies.
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
index 07becc36..d7516d0c 100644
--- a/protocols/CMakeLists.txt
+++ b/protocols/CMakeLists.txt
@@ -13,10 +13,21 @@ WAYLAND_ADD_PROTOCOL_SERVER(proto-server-desktop-shell
desktop-shell
)
+WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-swaylock
+ swaylock.xml
+ swaylock
+)
+WAYLAND_ADD_PROTOCOL_SERVER(proto-server-swaylock
+ swaylock.xml
+ swaylock
+)
+
add_library(sway-protocols
${proto-client-xdg-shell}
${proto-client-desktop-shell}
${proto-server-desktop-shell}
+ ${proto-client-swaylock}
+ ${proto-server-swaylock}
)
set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)