aboutsummaryrefslogtreecommitdiff
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-06-14 19:02:15 -0400
committerGitHub <noreply@github.com>2017-06-14 19:02:15 -0400
commit4e663ab44f5320f20ec2376f24ea1eb3b458f2c2 (patch)
treedcb3b74f1dde93bce8657b7509662ffd7db667d0 /protocols/CMakeLists.txt
parenteb6e38c86d2deb37cc6f378f8644c4a530fd7448 (diff)
parent298f56353ef155f6a2ccc977c96b2ff5d971e65e (diff)
Merge pull request #1199 from SirCmpwn/server-decoration
Implement KDE's server-side decoration protocol
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
index a9b459ab..8d8e58ad 100644
--- a/protocols/CMakeLists.txt
+++ b/protocols/CMakeLists.txt
@@ -27,6 +27,11 @@ WAYLAND_ADD_PROTOCOL_SERVER(proto-server-gamma-control
gamma-control
)
+WAYLAND_ADD_PROTOCOL_SERVER(proto-server-server-decoration
+ server-decoration.xml
+ server-decoration
+)
+
add_library(sway-protocols STATIC
${proto-client-xdg-shell}
${proto-client-desktop-shell}
@@ -34,6 +39,7 @@ add_library(sway-protocols STATIC
${proto-client-swaylock}
${proto-server-swaylock}
${proto-server-gamma-control}
+ ${proto-server-server-decoration}
)
set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)