aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-07-25 08:27:40 -0400
committerGitHub <noreply@github.com>2018-07-25 08:27:40 -0400
commitfc718f629af231f8a0ae795b2f7529e213cab183 (patch)
tree7917aadbfb09d02d3d60045f0ba8d5028f0c4bb4 /meson.build
parentfd1e2c172c12b5c5a3adac8e6de4009697bd7567 (diff)
parent384c55c0b465d6b9a9c4cb88d8752435ac5cf708 (diff)
downloadsway-fc718f629af231f8a0ae795b2f7529e213cab183.tar.xz
Merge pull request #2350 from ppascher/xwayland-optional
Added meson option to allow building sway without xwayland support
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1d40581a..06299618 100644
--- a/meson.build
+++ b/meson.build
@@ -48,6 +48,12 @@ git = find_program('git', required: false)
conf_data = configuration_data()
+if get_option('enable-xwayland')
+ conf_data.set('HAVE_XWAYLAND', true)
+else
+ conf_data.set('HAVE_XWAYLAND', false)
+endif
+
if gdk_pixbuf.found()
conf_data.set('HAVE_GDK_PIXBUF', true)
endif