aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-02-08 19:24:20 +0100
committerTudor Brindus <me@tbrindus.ca>2021-02-25 09:38:00 -0500
commiteea9c6331f01729d5feb8f86a4c0bbb53012d292 (patch)
tree087cd3b7341c8ddddca3425613858a6a4281ee49 /meson.build
parent641b8719ad7238cbc423c5575a58ac509bfcad02 (diff)
Automatically map built-in touchscreens/tablets to built-in panels
Detect whether an output is built-in via its type. Detect whether a touchscreen or tablet tool is built-in via its ID_PATH property.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cb4ee20e..60daf882 100644
--- a/meson.build
+++ b/meson.build
@@ -54,6 +54,7 @@ libinput = dependency('libinput', version: '>=1.6.0')
xcb = dependency('xcb', required: get_option('xwayland'))
drm_full = dependency('libdrm') # only needed for drm_fourcc.h
drm = drm_full.partial_dependency(compile_args: true, includes: true)
+libudev = dependency('libudev')
bash_comp = dependency('bash-completion', required: false)
fish_comp = dependency('fish', required: false)
math = cc.find_library('m')