aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-09-03 10:59:18 -0400
committerGitHub <noreply@github.com>2018-09-03 10:59:18 -0400
commite4afd33d478c14fd82e585eefe36b5576d78c5bb (patch)
treedd7397f8494a9ef8493674d550bafbc0333a8376 /meson.build
parent7d353813d502d50439a7d50b55304fc835f3c7fd (diff)
parent073dcb3a8650ee45bb98701fccd6530d9dd1a3f4 (diff)
Merge pull request #2542 from sghctoma/fix-freebsd-build
FreeBSD fixes
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index eb5cba84..253a4e96 100644
--- a/meson.build
+++ b/meson.build
@@ -38,7 +38,7 @@ pango = dependency('pango')
pangocairo = dependency('pangocairo')
gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
pixman = dependency('pixman-1')
-libcap = dependency('libcap')
+libcap = dependency('libcap', required: false)
libinput = dependency('libinput', version: '>=1.6.0')
libpam = cc.find_library('pam')
systemd = dependency('libsystemd', required: false)
@@ -104,7 +104,7 @@ if scdoc.found()
endforeach
endif
-add_project_arguments('-DSYSCONFDIR="/@0@"'.format(sysconfdir), language : 'c')
+add_project_arguments('-DSYSCONFDIR="/@0@/@1@"'.format(prefix, sysconfdir), language : 'c')
version = get_option('sway-version')
if version != ''