aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTadeo Kondrak <me@tadeo.ca>2021-02-23 11:47:38 -0700
committerSimon Ser <contact@emersion.fr>2021-02-23 20:27:38 +0100
commitde471e67d3cb4ec788cbf060dff48ad262cd315f (patch)
treee3a971013e457df16f72eb616c3130f3bb99d5f4 /meson.build
parent95901d906ade2c6698eee1f956e105508a21ab79 (diff)
build: Add dependency on libdrm
As of 66343839b146a54505b746784cd42a8efb844963, sway now uses a libdrm header. Add this dependency to the build system so headers from it can be used on systems where pkg-config is required to find them.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9177ca33..19cb5130 100644
--- a/meson.build
+++ b/meson.build
@@ -52,6 +52,8 @@ glesv2 = dependency('glesv2')
libevdev = dependency('libevdev')
libinput = dependency('libinput', version: '>=1.6.0')
xcb = dependency('xcb', required: get_option('xwayland'))
+drm_full = dependency('libdrm') # only needed for drm_fourcc.h
+drm = drm_full.partial_dependency(compile_args: true, includes: true)
bash_comp = dependency('bash-completion', required: false)
fish_comp = dependency('fish', required: false)
math = cc.find_library('m')