aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2022-11-28 20:09:10 +0100
committerSimon Zeni <simon@bl4ckb0ne.ca>2022-11-29 11:47:21 -0500
commitd41f11e6bd8cef80f02dda4c66d4a31611aed753 (patch)
tree5c3cdbba1723af492089524ed87c55e6b5fc0dc5 /meson.build
parenta358d6760ef751588d310f0141798387e7f4d4b1 (diff)
build: fix have_xwayland when xcb-icccm is not found
xcb-icccm is required to build Xwayland support.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e22bc36e..fa008332 100644
--- a/meson.build
+++ b/meson.build
@@ -86,7 +86,7 @@ rt = cc.find_library('rt')
xcb_icccm = dependency('xcb-icccm', required: get_option('xwayland'))
threads = dependency('threads') # for pthread_setschedparam
-have_xwayland = xcb.found() and wlroots_features['xwayland']
+have_xwayland = xcb.found() and xcb_icccm.found() and wlroots_features['xwayland']
if get_option('sd-bus-provider') == 'auto'
if not get_option('tray').disabled()