aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-09-26 16:37:23 -0500
committerGitHub <noreply@github.com>2018-09-26 16:37:23 -0500
commitd00a581ae01beef7159e87cb1cf2ecd5c2c19ca3 (patch)
treeee7b21a8980b30a8524e44c43e0cce6319ba9b4a /meson.build
parenta8a0014e0f25eefdf6712387c34e8d55614205ce (diff)
parent2f258eff6fd2c89a94caa658c1ea22beb76d728a (diff)
Merge pull request #2715 from sghctoma/add-c11_source
Use _C11_SOURCE feature test macro on FreeBSD (fixes #2616)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 82e4a96f..76eaff20 100644
--- a/meson.build
+++ b/meson.build
@@ -22,6 +22,10 @@ datadir = get_option('datadir')
sysconfdir = get_option('sysconfdir')
prefix = get_option('prefix')
+if is_freebsd
+ add_project_arguments('-D_C11_SOURCE', language: 'c')
+endif
+
swayidle_deps = []
jsonc = dependency('json-c', version: '>=0.13')