aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2019-01-18 08:21:43 +0100
committeremersion <contact@emersion.fr>2019-01-18 08:21:43 +0100
commitba16f16e4d5ac01690f9c2140c1f6682affd27cb (patch)
treedd32d8cfcf530d6f55924dab4eb0ce57a02803a8 /meson.build
parent08a5b304e4334020f46752697ad0e7cde54229f4 (diff)
meson: add gdk-pixbuf and man-pages options
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 8acf0f2c..1318ce8f 100644
--- a/meson.build
+++ b/meson.build
@@ -46,7 +46,7 @@ xkbcommon = dependency('xkbcommon')
cairo = dependency('cairo')
pango = dependency('pango')
pangocairo = dependency('pangocairo')
-gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
+gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: get_option('gdk-pixbuf'))
pixman = dependency('pixman-1')
libevdev = dependency('libevdev')
libinput = dependency('libinput', version: '>=1.6.0')
@@ -80,8 +80,7 @@ if not systemd.found() and not elogind.found()
warning('You must do this manually post-install: chmod a+s /path/to/sway')
endif
-scdoc = find_program('scdoc', required: false)
-
+scdoc = find_program('scdoc', required: get_option('man-pages'))
if scdoc.found()
sh = find_program('sh')
mandir = get_option('mandir')