aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-07-27 17:50:33 +0100
committerEric Engestrom <eric.engestrom@intel.com>2018-07-30 15:56:50 +0100
commitb9d531b3181a0877ea3b94d5f9aa5877bbddeb1b (patch)
tree0dd521bdaa228843b36f1c532a42f0bc3540d41f /meson.build
parentc4b4da5dc4ba9c68ff28ba2a01566b760adf1f55 (diff)
meson: install bash completion
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1cb40ade..5be1f8d2 100644
--- a/meson.build
+++ b/meson.build
@@ -191,3 +191,15 @@ if (get_option('zsh_completions'))
install_data(zsh_files, install_dir: zsh_install_dir)
endif
+
+if (get_option('bash_completions'))
+ bash_files = files(
+ 'completions/bash/sway',
+ 'completions/bash/swayidle',
+ 'completions/bash/swaylock',
+ 'completions/bash/swaymsg',
+ )
+ bash_install_dir = datadir + '/bash-completion/completions'
+
+ install_data(bash_files, install_dir: bash_install_dir)
+endif