aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-03-30 00:11:00 -0400
committerGitHub <noreply@github.com>2018-03-30 00:11:00 -0400
commit9d7f47746cdcb0eed3cf41875d06a8ef238eef1c (patch)
tree997658454de40db3f8b76b68d658efaf2b686188 /meson.build
parent7162b9bea4d66d61376ad3605e23e2d83bb95201 (diff)
parentf26ecd9f58bb672fe107660ce9b37f4bf0777a8c (diff)
downloadsway-9d7f47746cdcb0eed3cf41875d06a8ef238eef1c.tar.xz
Merge pull request #1648 from swaywm/swaybar-layers
Port swaybar to layer shell
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b681f43a..49824b30 100644
--- a/meson.build
+++ b/meson.build
@@ -35,6 +35,7 @@ pixman = dependency('pixman-1')
libcap = dependency('libcap')
libinput = dependency('libinput')
math = cc.find_library('m')
+rt = cc.find_library('rt')
git = find_program('git', required: false)
a2x = find_program('a2x', required: false)
@@ -99,8 +100,10 @@ subdir('protocols')
subdir('common')
subdir('sway')
subdir('swaymsg')
+
subdir('client')
subdir('swaybg')
+subdir('swaybar')
config = configuration_data()
config.set('sysconfdir', join_paths(prefix, sysconfdir))