aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-03-28 15:25:33 -0400
committerGitHub <noreply@github.com>2018-03-28 15:25:33 -0400
commit9070950eecded7bfa64e7bca3bb76b150ccc8b72 (patch)
tree509a9c669bf2679085e27a1ff1b0c95526abf14c /meson.build
parent45a50d5afe013b31d9c94090d990bca49448d396 (diff)
parentd39bda76c4007c42452a81883fefc671b816a74b (diff)
Merge pull request #1638 from swaywm/swaybg-layers
Reimplement swaybg using surface layers
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f27ac451..b681f43a 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,10 @@ wayland_client = dependency('wayland-client')
wayland_egl = dependency('wayland-egl')
wayland_protos = dependency('wayland-protocols')
xkbcommon = dependency('xkbcommon')
+cairo = dependency('cairo')
pango = dependency('pango')
+pangocairo = dependency('pangocairo')
+gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
pixman = dependency('pixman-1')
libcap = dependency('libcap')
libinput = dependency('libinput')
@@ -35,6 +38,12 @@ math = cc.find_library('m')
git = find_program('git', required: false)
a2x = find_program('a2x', required: false)
+conf_data = configuration_data()
+
+if gdk_pixbuf.found()
+ conf_data.set('HAVE_GDK_PIXBUF', true)
+endif
+
if a2x.found()
mandir = get_option('mandir')
man_files = [
@@ -85,9 +94,13 @@ add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
sway_inc = include_directories('include')
+subdir('include')
+subdir('protocols')
subdir('common')
subdir('sway')
subdir('swaymsg')
+subdir('client')
+subdir('swaybg')
config = configuration_data()
config.set('sysconfdir', join_paths(prefix, sysconfdir))