aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-10-17 16:14:35 +0200
committerGitHub <noreply@github.com>2018-10-17 16:14:35 +0200
commit46dafbf74a164fadf6de41c556d5cfc8a2fcee14 (patch)
tree70bcbb30dd628e463a462ab0adc8a9bbd3732fd0 /meson.build
parente46c3ffbc9f3cf51f08b3b9a0ae1c62e7ddd0a9a (diff)
parentaf2cfa52211d59ecfb6e3ccd9be4c7ccbd920268 (diff)
Merge pull request #2864 from sghctoma/freebsd-fixes
FreeBSD fixes
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 15 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3fb1e81e..1e2b53fa 100644
--- a/meson.build
+++ b/meson.build
@@ -114,7 +114,13 @@ if scdoc.found()
endforeach
endif
-add_project_arguments('-DSYSCONFDIR="/@0@"'.format(sysconfdir), language : 'c')
+# If prefix is '/usr', sysconfdir will be explicitly set to '/etc' by Meson to
+# enforce FHS compliance, so we should look for configs there as well.
+if prefix == '/usr'
+ add_project_arguments('-DSYSCONFDIR="/@0@"'.format(sysconfdir), language : 'c')
+else
+ add_project_arguments('-DSYSCONFDIR="/@0@/@1@"'.format(prefix, sysconfdir), language : 'c')
+endif
version = get_option('sway-version')
if version != ''
@@ -157,10 +163,17 @@ subdir('swaynag')
subdir('swaylock')
config = configuration_data()
-config.set('sysconfdir', sysconfdir)
config.set('datadir', join_paths(prefix, datadir))
config.set('prefix', prefix)
+# If prefix is '/usr', sysconfdir will be explicitly set to '/etc' by Meson to
+# enforce FHS compliance, so we should look for configs there as well.
+if prefix == '/usr'
+ config.set('sysconfdir', sysconfdir)
+else
+ config.set('sysconfdir', join_paths(prefix, sysconfdir))
+endif
+
configure_file(
configuration: config,
input: 'config.in',