aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-09-28 14:17:37 +0200
committerGitHub <noreply@github.com>2018-09-28 14:17:37 +0200
commit1698260533ea71791d07cfc9d0efab08fb893450 (patch)
treef1dcfbd0a59ce356f7d4cec1d076358e0d00e387 /meson.build
parent813de9f7ac674ad276b01df0f0fac39a7ba8fbdd (diff)
parentc9773491207d36d6f5e651adcb7a64c7a015bba3 (diff)
Merge pull request #2720 from swaywm/swaylock-shadow
Add support for building swaylock without PAM
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 6 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 76eaff20..de6573ea 100644
--- a/meson.build
+++ b/meson.build
@@ -74,6 +74,11 @@ if elogind.found()
swayidle_deps += elogind
endif
+if not systemd.found() and not elogind.found()
+ warning('The sway binary must be setuid when compiled without (e)logind')
+ warning('You must do this manually post-install: chmod a+s /path/to/sway')
+endif
+
scdoc = find_program('scdoc', required: false)
if scdoc.found()
@@ -139,10 +144,7 @@ subdir('swaybg')
subdir('swaybar')
subdir('swayidle')
subdir('swaynag')
-
-if libpam.found()
- subdir('swaylock')
-endif
+subdir('swaylock')
config = configuration_data()
config.set('sysconfdir', join_paths(prefix, sysconfdir))