aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-02-16 22:57:42 +0100
committerGitHub <noreply@github.com>2019-02-16 22:57:42 +0100
commit0bafc55176f97d2c5d991e8e5fb0e11a989b88d2 (patch)
tree0b907b10ec130b25944fdf8d4ec99c8e7bc5b80e /meson.build
parentf54077dbca2faf3f0d614377a01a215c82ef075e (diff)
parent859a884e82601044aa4c825cfbfdd53e2b4ef79c (diff)
Merge pull request #3701 from emersion/meson-subproject-disable-unneeded
Disable unneeded wlroots subproject features
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2336a148..cfd77ce7 100644
--- a/meson.build
+++ b/meson.build
@@ -60,7 +60,11 @@ rt = cc.find_library('rt')
git = find_program('git', required: false)
# Try first to find wlroots as a subproject, then as a system dependency
-wlroots_proj = subproject('wlroots', required: false)
+wlroots_proj = subproject(
+ 'wlroots',
+ default_options: ['rootston=disabled', 'examples=disabled'],
+ required: false,
+)
if wlroots_proj.found()
wlroots = wlroots_proj.get_variable('wlroots')
wlroots_conf = wlroots_proj.get_variable('conf_data')