aboutsummaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-03-28 15:25:33 -0400
committerGitHub <noreply@github.com>2018-03-28 15:25:33 -0400
commit9070950eecded7bfa64e7bca3bb76b150ccc8b72 (patch)
tree509a9c669bf2679085e27a1ff1b0c95526abf14c /common/meson.build
parent45a50d5afe013b31d9c94090d990bca49448d396 (diff)
parentd39bda76c4007c42452a81883fefc671b816a74b (diff)
Merge pull request #1638 from swaywm/swaybg-layers
Reimplement swaybg using surface layers
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build21
1 files changed, 16 insertions, 5 deletions
diff --git a/common/meson.build b/common/meson.build
index abe0cdcf..01736ca6 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -1,12 +1,23 @@
-lib_sway_common = static_library('sway-common',
+deps = [
+ cairo,
+ wlroots
+]
+
+if gdk_pixbuf.found()
+ deps += [gdk_pixbuf]
+endif
+
+lib_sway_common = static_library(
+ 'sway-common',
files(
+ 'cairo.c',
+ 'ipc-client.c',
'log.c',
'list.c',
- 'util.c',
- 'stringop.c',
'readline.c',
- 'ipc-client.c'
+ 'stringop.c',
+ 'util.c'
),
- dependencies: [ wlroots ],
+ dependencies: deps,
include_directories: sway_inc
)