aboutsummaryrefslogtreecommitdiff
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2015-12-21 20:42:08 -0500
committerDrew DeVault <sir@cmpwn.com>2015-12-21 20:42:08 -0500
commit91c102a897467ff1bae345458ccf096e32e7bd15 (patch)
tree104c612d08afef1566c9b56f962641bb39c0dc1b /common/CMakeLists.txt
parent5a13d19d4967cd90def4c29cd5ebfbaaa43bc1da (diff)
parentc3e9ee5e43c6d7adf6d5c9b74b39a5170cfe0b02 (diff)
Merge pull request #393 from robotanarchy/musl-libc-compatibility
musl libc compatibility
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index a40f096d..38767249 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -6,3 +6,10 @@ add_library(sway-common
readline.c
stringop.c
)
+
+if(Backtrace_FOUND)
+ set_target_properties(sway-common
+ PROPERTIES
+ COMPILE_FLAGS "-include ${Backtrace_HEADER}"
+ )
+endif()