aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2015-12-01 15:57:03 -0500
committerDrew DeVault <sir@cmpwn.com>2015-12-01 15:57:03 -0500
commitfc01f04c93c0de2a0cdcee946ac0131b86e18342 (patch)
tree204ba2fbc20298af8f159cd648c710b3a346135a /CMakeLists.txt
parent297d8b3f02a97c8b23fedd4185016e785f7e2fda (diff)
parent38d4ee9f5030ad8bf383c8c24b0b13b20dbc45de (diff)
Merge pull request #287 from christophgysin/cmake
cmake: extract config from toplevel CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt84
1 files changed, 3 insertions, 81 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48f03e2e..b9a2e37d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git)
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)
execute_process(
- COMMAND git rev-parse --abbrev-ref HEAD
+ COMMAND git rev-parse --abbrev-ref HEAD
OUTPUT_VARIABLE GIT_BRANCH
OUTPUT_STRIP_TRAILING_WHITESPACE
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
@@ -43,91 +43,13 @@ add_definitions(-DSWAY_VERSION_DATE=\"${CURRENT_DATE}\")
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+add_subdirectory(sway)
add_subdirectory(swaybg)
add_subdirectory(swaymsg)
add_subdirectory(swaygrab)
add_subdirectory(swaybar)
-find_package(XKBCommon REQUIRED)
-find_package(WLC REQUIRED)
-find_package(A2X REQUIRED)
-find_package(PCRE REQUIRED)
-find_package(Wayland REQUIRED)
-find_package(JsonC REQUIRED)
-
-file(GLOB sources ${PROJECT_SOURCE_DIR}/sway/*.c)
-file(GLOB common ${PROJECT_SOURCE_DIR}/common/*.c)
-
-include(Wayland)
-WAYLAND_ADD_PROTOCOL_SERVER(proto-desktop-shell
- ${PROJECT_SOURCE_DIR}/protocols/desktop-shell.xml
- desktop-shell
-)
-
-include_directories(
- ${WLC_INCLUDE_DIRS}
- ${PCRE_INCLUDE_DIRS}
- ${JSONC_INCLUDE_DIRS}
- ${XKBCOMMON_INCLUDE_DIRS}
- ${CMAKE_CURRENT_BINARY_DIR}
-)
-
-add_executable(sway
- ${sources}
- ${common}
- ${proto-desktop-shell}
-)
-
-target_link_libraries(sway
- ${WLC_LIBRARIES}
- ${XKBCOMMON_LIBRARIES}
- ${PCRE_LIBRARIES}
- ${JSONC_LIBRARIES}
- ${WAYLAND_SERVER_LIBRARIES}
-)
-
-install(
- TARGETS sway
- RUNTIME
- DESTINATION bin
- COMPONENT runtime
-)
-install(
- FILES ${CMAKE_CURRENT_SOURCE_DIR}/config
- DESTINATION ${FALLBACK_CONFIG_DIR}
- COMPONENT configuration
-)
-
-add_custom_target(man ALL)
-
-function(add_manpage name section)
- add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${name}.${section}
- COMMAND ${A2X_COMMAND}
- --no-xmllint
- --doctype manpage
- --format manpage
- -D ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}
- ${CMAKE_CURRENT_SOURCE_DIR}/${name}.${section}.txt
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${name}.${section}.txt
- COMMENT Generating manpage for ${name}.${section}
- )
-
- add_custom_target(man-${name}.${section}
- DEPENDS
- ${CMAKE_CURRENT_BINARY_DIR}/${name}.${section}
- )
- add_dependencies(man
- man-${name}.${section}
- )
-
- install(
- FILES ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${name}.${section}
- DESTINATION share/man/man${section}
- COMPONENT documentation
- )
-endfunction()
-
+include(Manpage)
add_manpage(sway 1)
add_manpage(sway 5)
add_manpage(swaymsg 1)