aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorrobotanarchy <robotanarchy@bingo-ev.de>2015-12-21 19:01:17 +0100
committerrobotanarchy <robotanarchy@bingo-ev.de>2015-12-21 19:01:17 +0100
commit94cac7a0149a8c1c48f33b0a8140edec5581ce64 (patch)
tree285f92b207907fe8876a749c079ed56f6a3c7373 /CMakeLists.txt
parent3dd23937974dea9a2c9205431e3cf2275290f162 (diff)
use CMake's FindBacktrace for backtrace feature detection
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cd9c67b..cabdc468 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,6 +58,14 @@ find_package(Pango)
find_package(GdkPixbuf)
find_package(PAM)
+find_package(Backtrace)
+if(Backtrace_FOUND)
+ include_directories(${Backtrace_INCLUDE_DIRS})
+ target_link_libraries(${Backtrace_LIBRARIES})
+ add_definitions(-DSWAY_Backtrace_FOUND=1)
+ set(SWAY_Backtrace_HEADER "${Backtrace_HEADER}")
+endif()
+
include(FeatureSummary)
include(Manpage)