aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjohalun <johalun0@gmail.com>2017-06-05 13:44:29 +0200
committerjohalun <johalun0@gmail.com>2017-06-06 09:45:50 +0200
commit7fef2830446e1f98a02f8d8a3bba866b7edd5bd0 (patch)
tree10c1529eb56235b303bdbca905e8b80dce47ae6d /CMakeLists.txt
parent5ed533a94331ea2d849f900ee20f8932d742e9b5 (diff)
FreeBSD fixes
Increase _POSIX_SOURCE value where needed. Increase _XOPEN_SOURCE value where needed. Conditionally link to libcap (only on Linux). Possibly some trailing whitespace fixes (automatic).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ed45830..edf486ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,10 @@ find_package(GdkPixbuf)
find_package(PAM)
find_package(LibInput REQUIRED)
-find_package(Libcap REQUIRED)
+
+if (CMAKE_SYSTEM_NAME STREQUAL Linux)
+ find_package(Libcap REQUIRED)
+endif (CMAKE_SYSTEM_NAME STREQUAL Linux)
if (CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
find_package(EpollShim REQUIRED)