aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2016-12-27 19:38:54 -0500
committerDrew DeVault <sir@cmpwn.com>2016-12-27 19:39:37 -0500
commit6a1df17fb7f7bcfa26d825173de4d31b771fd7a6 (patch)
tree35c64123e10960b7fe24f4e27b96ecf4ef871dcc /CMakeLists.txt
parent1882cb673394303e858642d3f688108400950a6c (diff)
Fix user-set LD_LIBRARY_PATH
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1c38ce3..ea0e3648 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,7 +47,7 @@ option(enable-swaymsg "Enables the swaymsg utility" YES)
option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
option(zsh-completions "Zsh shell completions" NO)
option(default-wallpaper "Installs the default wallpaper" YES)
-option(LD_LIBRARY_PATH "Configures sway's default LD_LIBRARY_PATH" "/usr/lib")
+set(LD_LIBRARY_PATH "/usr/lib" CACHE STRING "Configures sway's default LD_LIBRARY_PATH")
add_definitions(-D_LD_LIBRARY_PATH="${LD_LIBRARY_PATH}")