aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-07-03 14:40:06 -0600
committerGitHub <noreply@github.com>2017-07-03 14:40:06 -0600
commit401b80501a6b285562f83ab7e47a7062e91a6e77 (patch)
tree9e3f94462da0dd840cf50c7a724145e6d5b5473c /CMakeLists.txt
parentba78ea3e5fcb0813a779f26269c34aba9b341c16 (diff)
parentc8370c96991cb8af647e46e5067b6c6641eacec4 (diff)
Merge pull request #1259 from Hummer12007/patch-4
Disable -Wunused-result diagnostic
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0257a99f..a4bf351b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/bin)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-unused-parameter")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-unused-result")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
if (CMAKE_COMPILER_IS_GNUCC)
if(NOT CMAKE_C_COMPILER_VERSION VERSION_LESS 7.0)