aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYacine Hmito <yacine.hmito@gmail.com>2015-12-01 00:38:23 +0100
committerYacine Hmito <yacine.hmito@gmail.com>2015-12-01 01:07:48 +0100
commit09feef89eea03527c9c81b8d15fe8c1474942209 (patch)
tree4a9ecf5416f6e109f60aa6834eec43cba5267d5d /CMakeLists.txt
parent44d0f731c36661a192d0fb9d65822eebef7d0092 (diff)
Can customize config fallback directory
CMake takes a `FALLBACK_CONFIG_DIR` flag which is the directory where the standard configuration file `config` is copied at installation. If loading from typical configuration directories fails, sway loads FALLBACK_CONFIG_DIR/config (/etc/sway/config by default).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1298a2ce..9e1e1dde 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,9 @@ cmake_minimum_required(VERSION 3.1.0)
project(sway C)
+set(FALLBACK_CONFIG_DIR "/etc/sway/")
+add_definitions('-DFALLBACK_CONFIG_DIR=\"${FALLBACK_CONFIG_DIR}\"')
+
set(CMAKE_C_FLAGS "-g")
set(CMAKE_C_STANDARD 99)
SET(CMAKE_C_EXTENSIONS OFF)
@@ -80,7 +83,7 @@ install(
COMPONENT runtime)
install(
FILES "${CMAKE_CURRENT_SOURCE_DIR}/config"
- DESTINATION /etc/sway/
+ DESTINATION "${FALLBACK_CONFIG_DIR}"
COMPONENT configuration)
add_custom_target(man ALL)