aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 35e7460..59a773f 100644
--- a/meson.build
+++ b/meson.build
@@ -21,11 +21,13 @@ add_project_arguments(
'-Wstrict-prototypes',
'-Wimplicit-fallthrough',
'-Wmissing-prototypes',
- '-Wno-unknown-warning',
+ '-Wno-unknown-warning-option',
+ '-Wno-unused-command-line-argument',
'-Wvla',
'-Wl,--exclude-libs=ALL',
'-fvisibility=hidden',
'-D_XOPEN_SOURCE=700',
+ '-D__BSD_VISIBLE',
],
language: 'c',
)