aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7a70cb6..6299f4e 100644
--- a/meson.build
+++ b/meson.build
@@ -106,8 +106,11 @@ with_seatd = get_option('seatd') == 'enabled'
with_builtin = get_option('builtin') == 'enabled'
with_server = get_option('server') == 'enabled'
-if with_seatd
+if with_seatd or with_builtin
private_files += 'libseat/backend/seatd.c'
+endif
+
+if with_seatd
add_project_arguments('-DSEATD_ENABLED=1', language: 'c')
endif