aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-03-26 10:07:00 +0100
committerKenny Levinsen <kl@kl.wtf>2021-03-26 11:21:05 +0100
commitfa2700126fe355939744a5e77159e7fc4a631575 (patch)
tree6107c76084906adf51cbb10b56dbccabc61b5e70 /meson.build
parent9a7824b7c3ff5c957632671e91454fc84fbcdda8 (diff)
meson: declare libseat dependency
This can be used by parent projects when seatd is a subproject: libseat = dependency('libseat', fallback: ['seatd', 'libseat'])
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c3800ae..482f877 100644
--- a/meson.build
+++ b/meson.build
@@ -164,6 +164,12 @@ pkgconfig.generate(lib,
description: 'Seat management library',
)
+libseat = declare_dependency(
+ link_with: lib,
+ dependencies: private_deps,
+ include_directories: include_directories('include', is_system: true),
+)
+
if get_option('server').enabled()
executable(
'seatd',