aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-04-07 13:36:41 +0200
committerKenny Levinsen <kl@kl.wtf>2021-04-08 23:07:35 +0200
commitee409138109c5f53310f0d81d2b591157b39d622 (patch)
tree8cfcd03b66c7b6931d0bdefd1a0ec2081ece81b5 /meson.build
parent392da918e626641edb337d0afd9c0d72695babed (diff)
build: don't explicitly search for sh
This removes the "Program sh found" line in the build logs, and should not change anything else.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8f7efb2..60c96f0 100644
--- a/meson.build
+++ b/meson.build
@@ -214,7 +214,6 @@ else
endif
if scdoc.found()
- sh = find_program('sh', native: true)
scdoc_prog = find_program(scdoc.get_pkgconfig_variable('scdoc'), native: true)
mandir = get_option('mandir')
@@ -228,7 +227,7 @@ if scdoc.found()
input: 'man/' + src,
output: output,
command: [
- sh, '-c', '@0@ < @INPUT@ > @1@'.format(scdoc_prog.path(), output)
+ 'sh', '-c', '@0@ < @INPUT@ > @1@'.format(scdoc_prog.path(), output)
],
install: true,
install_dir: '@0@/man@1@'.format(mandir, section)