aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d074946e..5210861e 100644
--- a/meson.build
+++ b/meson.build
@@ -46,7 +46,7 @@ pam_dep = dependency('pam', required: false)
if not pam_dep.found()
pam_dep = cc.find_library('pam', required: false)
endif
-if pam_dep.found()
+if pam_dep.found() and get_option('pam')
cc_pam_flags = '-DHAVE_PAM'
else
cc_pam_flags = []