aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ea2b9a5d..00c4f2d9 100644
--- a/meson.build
+++ b/meson.build
@@ -43,6 +43,9 @@ else
endif
pam_dep = dependency('pam', required : get_option('pam'))
+if not pam_dep.found()
+ pam_dep = cc.find_library('pam', required : get_option('pam'))
+endif
if pam_dep.found()
cc_pam_flags = '-DHAVE_PAM'
else
@@ -91,6 +94,9 @@ if selinux_dep.found()
cc_selinux_flags = '-DHAVE_SELINUX'
if pam_dep.found()
pam_misc_dep = dependency('pam_misc', required : get_option('pam'))
+ if not pam_misc_dep.found()
+ pam_misc_dep = cc.find_library('pam_misc', required : get_option('pam'))
+ endif
endif
else
cc_selinux_flags = []