aboutsummaryrefslogtreecommitdiff
path: root/src/start-stop-daemon/meson.build
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2022-04-06 10:51:55 -0500
committerWilliam Hubbs <w.d.hubbs@gmail.com>2022-04-06 10:51:55 -0500
commit391d12db48754861b5cecac92ee3321597ee02c1 (patch)
treeb42fad5a31ca342de7b7ecf1fb78784194c1400c /src/start-stop-daemon/meson.build
parent0efc1b133e4182bd53cde78153bd8b5cc2e99448 (diff)
migrate fully to meson build system
- drop old build system - move shared include and source files to common directory - drop "rc-" prefix from shared include and source files - move executable-specific code to individual directories under src - adjust top-level .gitignore file for new build system This closes #489.
Diffstat (limited to 'src/start-stop-daemon/meson.build')
-rw-r--r--src/start-stop-daemon/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/start-stop-daemon/meson.build b/src/start-stop-daemon/meson.build
new file mode 100644
index 00000000..39229132
--- /dev/null
+++ b/src/start-stop-daemon/meson.build
@@ -0,0 +1,15 @@
+executable('start-stop-daemon',
+ ['start-stop-daemon.c', 'rc-pipes.c', misc_c, schedules_c,
+ selinux_c, usage_c, version_h],
+ c_args : [cc_audit_flags, cc_branding_flags, cc_pam_flags, cc_cap_flags, cc_selinux_flags],
+ link_with: [libeinfo, librc],
+ dependencies: [audit_dep, dl_dep, pam_dep, cap_dep, pam_misc_dep, util_dep, selinux_dep, crypt_dep],
+ include_directories: [incdir, einfo_incdir, rc_incdir],
+ install: true,
+ install_dir: sbindir)
+
+if get_option('pam')
+ install_data('start-stop-daemon.pam',
+ rename : 'start-stop-daemon',
+ install_dir : pamdir)
+endif