aboutsummaryrefslogtreecommitdiff
path: root/src/librc/meson.build
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2024-03-20 23:45:47 +0100
committerAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2024-07-19 20:40:28 +0200
commitc34fcd63f05044f9034b26c52f19c91e04668da7 (patch)
tree8ef449218cf736057197cd39fba1dac6117216c3 /src/librc/meson.build
parent917a7031d946c0b608517936fab0f54689167265 (diff)
openrc: dynamic paths for user services
add two api functions, `rc_service_dir` and `rc_sysconf_dir`, both are generate paths (and sub-paths) for resources, and meant to replace the hardcoded variables like `RC_SVCDIR`. those functions differ by dynamically switching between the system path, or the user path, set in their home folder or runtime directory. this lays out the intial support for user services. Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev>
Diffstat (limited to 'src/librc/meson.build')
-rw-r--r--src/librc/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/librc/meson.build b/src/librc/meson.build
index 30caa1f3..8d963208 100644
--- a/src/librc/meson.build
+++ b/src/librc/meson.build
@@ -27,6 +27,7 @@ librc = library('rc', librc_sources,
dependencies: kvm_dep,
include_directories : [incdir, einfo_incdir],
link_depends : 'rc.map',
+ link_with : libeinfo,
version : librc_version,
install : true,
install_dir : libdir)