aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2022-04-16 15:13:08 -0500
committerGitHub <noreply@github.com>2022-04-16 15:13:08 -0500
commitfdfa6dbb0e69742029d53f0e163b8e7e7e6860f5 (patch)
tree6a300ef3e1b25e22224b042cc8a8c07b43709950 /meson.build
parent0b3f8750e7d307987eef9e63e327488a81c29a71 (diff)
rewrite tests (#515)
* rewrite tests to work with meson This ports our tests to meson and makes them able to be run in parallel. * add tests to ci * rewrite test/check-trailing-newlines in bash This test was using a GNU sed command which does not work on Alpine Linux.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d37910c3..11d146a5 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project('OpenRC', 'c',
'prefix=/usr',
'warning_level=3',
],
- meson_version : '>=0.53.0')
+ meson_version : '>=0.53.2')
cc = meson.get_compiler('c')
fs = import('fs')
@@ -205,6 +205,7 @@ subdir('sh')
subdir('src')
subdir('support')
subdir('sysctl.d')
+subdir('test')
subdir('zsh-completion')
meson.add_install_script('tools/meson_runlevels.sh',