aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9f4fc5ee..a9345e4c 100644
--- a/meson.build
+++ b/meson.build
@@ -59,6 +59,12 @@ else
cc_pam_flags = []
endif
+if get_option('user_services')
+ cc_user_services_flags = '-DRC_USER_SERVICES'
+else
+ cc_user_services_flags = []
+endif
+
if not pam_dep.found() and get_option('pam')
error('Pam was requested but could not be located')
endif