aboutsummaryrefslogtreecommitdiff
path: root/support/xinit/meson.build
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-06-23 13:54:38 -0300
committerAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-10-19 10:56:54 +0200
commite65da5598722160418b6faf772ea82ebd1eab7ed (patch)
treebe64da88531227e61d1fcdbe63ba6f62c014f861 /support/xinit/meson.build
parent9466109aabfcb818a5ca2d8c494acff73f34e7a4 (diff)
support: add xinit script for the dbus user services
when running dbus under a graphical environment, it needs DISPLAY and XAUTHORITY set in order to auto-launch graphical applications. but when started via pam, or any way outside the gui, they won't be set. this installs a script to be auto-ran by xinit, that loads the variables in dbus. Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev>
Diffstat (limited to 'support/xinit/meson.build')
-rw-r--r--support/xinit/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/support/xinit/meson.build b/support/xinit/meson.build
new file mode 100644
index 00000000..ba2b8cac
--- /dev/null
+++ b/support/xinit/meson.build
@@ -0,0 +1,6 @@
+xinit_bin = ['50-openrc-user.sh']
+xinit_dir = get_option('sysconfdir') / 'X11/xinit/xinitrc.d'
+
+install_data(xinit_bin,
+ install_dir : xinit_dir,
+ install_mode : 'rwxr-xr-x')