aboutsummaryrefslogtreecommitdiff
path: root/src/rc/meson.build
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2021-12-29 19:04:06 -0600
committerWilliam Hubbs <w.d.hubbs@gmail.com>2021-12-29 19:04:06 -0600
commitfd709885872e6392b5f4cb3363cc29a8f0a617c3 (patch)
tree76ddede57e6feb0276da13620846a2d925191f9c /src/rc/meson.build
parentcab458e27afe8dda78bef7c3605830f418d83ed1 (diff)
remove separate pam directory
Diffstat (limited to 'src/rc/meson.build')
-rw-r--r--src/rc/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/rc/meson.build b/src/rc/meson.build
index c76587c2..8b3fd205 100644
--- a/src/rc/meson.build
+++ b/src/rc/meson.build
@@ -100,6 +100,14 @@ executable('start-stop-daemon',
install: true,
install_dir: sbindir)
+if get_option('pam')
+ pam_dir = get_option('sysconfdir') / 'pam.d'
+
+ install_data('start-stop-daemon.pam',
+ rename : 'start-stop-daemon',
+ install_dir : pam_dir)
+endif
+
executable('supervise-daemon',
['supervise-daemon.c', rc_misc_c, rc_plugin_c, rc_schedules_c,
usage_c, version_h],
@@ -110,6 +118,14 @@ executable('supervise-daemon',
install: true,
install_dir: sbindir)
+if get_option('pam')
+ pam_dir = get_option('sysconfdir') / 'pam.d'
+
+ install_data('supervise-daemon.pam',
+ rename : 'supervise-daemon',
+ install_dir : pam_dir)
+endif
+
if os == 'Linux'
executable('openrc-init',
['openrc-init.c', rc_plugin_c, rc_wtmp_c, version_h],