aboutsummaryrefslogtreecommitdiff
path: root/src/rc-sstat/meson.build
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2022-04-06 10:51:55 -0500
committerWilliam Hubbs <w.d.hubbs@gmail.com>2022-04-06 10:51:55 -0500
commit391d12db48754861b5cecac92ee3321597ee02c1 (patch)
treeb42fad5a31ca342de7b7ecf1fb78784194c1400c /src/rc-sstat/meson.build
parent0efc1b133e4182bd53cde78153bd8b5cc2e99448 (diff)
migrate fully to meson build system
- drop old build system - move shared include and source files to common directory - drop "rc-" prefix from shared include and source files - move executable-specific code to individual directories under src - adjust top-level .gitignore file for new build system This closes #489.
Diffstat (limited to 'src/rc-sstat/meson.build')
-rw-r--r--src/rc-sstat/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/rc-sstat/meson.build b/src/rc-sstat/meson.build
new file mode 100644
index 00000000..85b7a5f0
--- /dev/null
+++ b/src/rc-sstat/meson.build
@@ -0,0 +1,5 @@
+if os == 'Linux'
+ install_data('rc-sstat',
+ install_dir: sbindir,
+ install_mode: 'rwxr-xr-x')
+endif