aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2023-08-30 13:20:16 +0200
committerWilliam Hubbs <w.d.hubbs@gmail.com>2023-09-12 22:53:12 -0500
commite447562aaadc96f8f95d6659e4776ce5c1a6c9d6 (patch)
tree442e95dd3c1b7283f9e96f2716625d0122542d47 /meson.build
parentc199c5cf6e39d6e21b92bddba7beeebcc3afca79 (diff)
start-stop-daemon: set fds to CLOEXEC instead of closing
Set file descriptors to CLOEXEC instead of closing them before exec, similar to what we do in supervise-daemon. Use the share cloexec_fds_from() helper for this. closefrom() is no longer used so remove the test.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 4ef3f38e..e77cae09 100644
--- a/meson.build
+++ b/meson.build
@@ -195,9 +195,6 @@ if cc.compiles(malloc_attribute_test, name : 'malloc attribute with arguments')
add_project_arguments('-DHAVE_MALLOC_EXTENDED_ATTRIBUTE', language: 'c')
endif
-if cc.has_function('closefrom', prefix: '#define _GNU_SOURCE\n#include <unistd.h>')
- add_project_arguments('-DHAVE_CLOSEFROM', language: 'c')
-endif
if cc.has_function('close_range', prefix: '#define _GNU_SOURCE\n#include <unistd.h>')
add_project_arguments('-DHAVE_CLOSE_RANGE', language: 'c')
endif